ROS軟路由論壇 ROSABC.com

 找回密碼
 會員注冊
查看: 64807|回復: 1173
打印 上一主題 下一主題

[Configuration基礎配置] [第一次登陸 RouterOS] 在你安裝完成 RouterOS 后,準備第一次

  [復制鏈接]
跳轉到指定樓層
樓主
發表于 2013-4-21 01:17:40 | 只看該作者 回帖獎勵 |倒序瀏覽 |閱讀模式
ROS軟路由論壇
本帖最后由 rosabc 于 2013-4-21 01:55 編輯

第一次登陸 RouterOS

在你安裝完成 RouterOS 后,準備第一次登陸 RouterOS,這里將告訴你如何連接到 RouterOS

方式1:Console 連接

如果你的設備是 RouterBOARD,沒有顯示器接口連接功能,你必須找到一條 Console 線(普通的 Console線),或者采用方式 2。

任何 PC 通過標準的 DB9 模式串口線連接到路由器,PC 串口連接的默認設置為每秒位數:9600 bits/s (RouterBOARD 系列串口是 115200 bits/s),使用終端仿真程序(如在 windows 中的超級終端或 SecureCRT,UNIX/Linux 的 minicom)連接到路由器。超級終端的具體參數設置如下:

將 Console 線的一端插到路由設備的 Console 口上,另一端插到 PC 上(運行 windows 或者 linux 操作系統), 如果你 PC 沒有 Console 口,你可以使用一個 USB-Serial 適配器(USB 轉串口適配器),然后運行一個終端 程序 HyperTerminal 或者 Putty(windowsXP 以前系統都自帶有超級終端,Vista 和 win7 可以將 windowsXP 的超級終端文件拷貝直接使用,文件 hypertrm.dll 和 hypertrm.exe)。RouterBOARD 連接參數如下:
游客,如果您要查看本帖隱藏內容請回復

基于 PC 的 RouterOS 連接參數:

通過以上配置你可以連接到 RouterOS,通過配置參數實現你的要去,具體參考相應的配置手冊

串口連接線(Null-modem 連接線)

下面是串口連接線的線序:

在路由器啟動完成后,會發出連續兩聲短觸“嘀嘀”的明鳴音,之后在顯示屏上,出現登錄的提示,如果在終端 顯示中,沒有提示任何信息,需要檢查一下網線或是串口線是否連接好。

串口控制(管理端)功能允許通過一個 MikroTik Router 串行接口訪問路由器的串口終端控臺一個特殊的串行 接口線通過工作站或者便攜式電腦的串口(COM)連接到路由器的串口。在 windows 電腦上常用的串口連接 程序是超級終端(HyperTerminal)。


串口控制線配置

基于 PC 的 RouterOS 的 DB9 串口線序排列如下:

Router Side (DB9f) Signal Direction Side (DB9f)
1, 6 CD, DSRIN 4
2 RxD IN 3
3 TxD OUT 2
4 DTR OUT 1, 6
5 GND - 5
7 RTS OUT 8
8 CTS IN 7

基于 RouterBOARD 系列的串口線序如下:

DB9f 功能 DB9f DB25f 1+4+6 CD+DTR+DSR 1+4+6 6+8+20
2 RxD 3 2
3 xD 2 3
5 GND 5 7
7+8 RTS+CTS 7+8 4+5

注:MikroTik RouterOS 需要定義以上的串口線序,才可以正常通信。

方式 2,Winbox 和 MAC telnet

你可以下載 winbox 應用程序,通過網上搜索可以找到,或者鏈接 WinBox。下載完成后你要確定你的電腦與路由器已通過以太網線連接,或者他們兩個連接在同一局域網內的交換機上。

運行 winbox,點擊


按鈕,winbox 會尋找你的路由器 MAC 地址,如果找到將會顯示在 winbox 列表框內, 選擇連接并登陸,你可以設置一下初始化參數,但最好配置一個 IP 地址到對應接口上,通過 IP 連接到 RouterOS,因為通過 MAC 連接設備不是 100%的可靠。


這個方法適用于任何 RouterOS 設備,注意你的 PC 網卡的 MTU 值必須是 1500

方式 3.顯示+鍵盤

如果將 RouterOS 安裝到 PC 上,簡單的方式就是通過顯示+鍵盤進行配置(注意:RouterBOARD 產品不支持, 僅采用方法 1 和方法 2) ,啟動后可以在顯示屏上看到如下登陸提示:

MikroTik v5.0
Login:

輸入登陸名 admin 回車后,密碼為空,你可以看到如下信息 as the login name, and hit enter twice

(because there is no password yet), you will see this screen:

MikroTik RouterOS 5.0 (c) 1999-2011 http://www.kreolwines.com/ Terminal ansi detected, using single line input mode


[RouterOS@ROSABC] >

現在你可以配置路由器了,你可以通過 setup 命令進行向導配置

Winbox 與 web 登錄

MikroTik RouterOS 內能通過遠程配置各種參數,包括 Telnet, SSH, WinBox 和 Webbox。在這里 我們將著重介紹怎樣使用 WinBox:


MAC-telnet 是在路由器沒有 IP 地址的情況下或者配置防火墻參數后無法連接,通過路由器網卡 MAC 地址登錄的方式遠程連接到路由器。MAC-telnet 僅能使用在來自同一個廣播域中(因此在網絡中不能有路由的存在), 且路由器的網卡應該被啟用。注:在 Winbox 中嵌入了通過 MAC 地址連接路由器的功能,并內置了探測工具。 這樣在管理員忘記或復位了路由器后,同樣可以通過 MAC 登陸到 RouterOS 上,進行圖形界面操作。

注:在 winbox2.2.12 后增加了可選擇的 MAC 登陸或者 IP 登陸的功能

Winbox 控制臺是用于 MikroTik RouterOS 的管理和配置,使用圖形管理接口(GUI)。通過連接到 MikroTik 路由器的 HTTP(TCP 80 端口)歡迎界面下載 Winbox.exe 可執行文件 ,下載并保存在你的 Windows 中, 之后直接在你 Windows 電腦上運行 Winbox.exe 文件

下面是對相應的功能鍵做介紹:

--


搜索和顯示 MNDP (MikroTik Neighbor Discovery Protocol) 或 CDP (Cisco Discovery Protocol) 設備。可以通過該功能鍵搜索同一子網內 MikroTik 和 Cisco 設備。并能通過 MAC 地址登陸到 MikroTik RouterOS 進行操作。


注:在 winbox2.2.12 后的版本增加了 MAC 地址和 IP 地址選擇功能,可根據搜索內容選擇使用 MAC

地址連接或是 IP 地址連接。

--

通過指定的 IP 地址(默認端口為 80,不許特別指定,如果你修改了端口需要對具體訪問端口做自定)

或 MAC 地址(如果路由器在同一子網內)登陸路由器。

--

保存當前連接列表(當需要運行它們時,只需雙擊)

--

刪除從列表中選擇的項目

--  

刪除所有列表中的項目,清除在本地的緩存,從 wbx 文件導入地址或導出為 wbx 文件

-- Secure Mode(安全模式):提供保密并在 winbox 和 RouterOS 之間使用 TLS(Transport Layer

Security)協議

-- Keep Password(保存密碼):保存密碼到本地磁盤的文本文件中

Winbox 控制臺使用 TCP 8291 端口,在登陸到路由器后可以通過 Winbox 控制臺操作 MikroTik 路由器的配 置并執行與本地控制臺同樣的任務。

命令功能概述

下面是對 Winbox 控制臺的操作按鈕:

圖標  功能    圖標     功能
添加一條項目
定義或編輯一個注釋
刪除一條存在項目
查詢關鍵字
啟用一個項目
撤銷操作
禁用一條項目
恢復操作

Winbox 常用管理


故障分析

-- 我能在 Linux 上運行 Winbox?

能,使用 Wine 圖形接口,可以運行 Winbox 并連接到 RouterOS。

-- 我不能打開 Winbox 控制臺

檢查路由器上/ip service print 的 www 服務端口和地址是否正確,確定地址是你能連接到的指定 網絡,確定端口為你指定的端口。如果你的服務端口和訪問地址被修改,你可以通過下面的命令設置回 默認值 /ip service set www port=80 address=0.0.0.0/0 。Winbox 控制臺使用 TCP8291 端口在防火墻中是否做了訪問限制。

Webbox 界面

當你配置好 RouterOS 的 IP 地址后,通過在瀏覽器中輸入 http://RouterIP 可以訪問到 RouterOS 的

web 頁面,我們在右上角輸入 RouterOS 的登陸帳號和密碼進入 webbox。

下面是 webbox 的頁面,在 webbox 中只能對 RouterOS 的一些基本參數配置,不能進行詳細的網絡配置,主 要包括 IP 地址、路由、防火墻(建議不要除 NAT 可以使用外,其他不要啟用以免無法登陸),基于 simple 的 流量控制、PPPoE 和 DHCP。

Webfig 配置頁面,完全是 winbox 的 web 版本,使管理員有更多方式對 RouterOS 進行管理

MAC 層訪問 (Telnet 與 Winbox)

通過 MAC 地址進行鏈接是用來訪問沒有設置 IP 地址的 RouterOS 路由設備. 這種連接類似于 IP 地址連接. 通過 MAC 地址僅在限于 2 臺 MikroTik RouterOS 路由器之間進行.



操作路徑: /tool mac-server

屬性描述

interface (name | all; 默認: all) –連接 MAC 服務器客戶端的接口名

all – 所有接口

注:這是一個在菜單選項的接口列表.如果你添加一些接口進列表, 你就能允許通過 mac 地址連接這些接口. Disabled (disabled=yes) 狀態的意思是不允許在接口列表中添加的接口通過 mac 地址進行訪問. all interfaces 默認設置為允許任何接口進行 mac 地址遠程訪問.

使只有 ether1 interface 能通過 mac 遠程訪問服務器:


[RouterOS@ROSABC] tool mac-server> print
Flags: X - disabled
# INTERFACE
0 all

[RouterOS@ROSABC] tool mac-server> remove 0

[RouterOS@ROSABC] tool mac-server> add interface=ether1 disabled=no

[RouterOS@ROSABC] tool mac-server> print
Flags: X - disabled
# INTERFACE
0 ether1

[RouterOS@ROSABC] tool mac-server>

MAC WinBox Server



操作路徑: /tool mac-server mac-winbox

屬性描述

interface (name | all; 默認: all) – 允許使用 mac 地址的協議連接的接口名

all – 所有接口

注:這是一個在菜單選項的接口列表. 如果你添加接口在列表中, 即允許通過 mac 地址訪問到這個接口. Disabled (disabled=yes) 意思是在這些接口中是不允許使用 mac 地址連接的接口.

僅啟用 ether1 接口的 MAC 服務器


[RouterOS@ROSABC] tool mac-server mac-winbox> print
Flags: X - disabled
# INTERFACE
0 all

[RouterOS@ROSABC] tool mac-server mac-winbox> remove 0

[RouterOS@ROSABC] tool mac-server mac-winbox> add interface=ether1 disabled=no

[RouterOS@ROSABC] tool mac-server mac-winbox> print
Flags: X - disabled
# INTERFACE
0 ether1

[RouterOS@ROSABC] tool mac-server mac-winbox>

動態監控列表



操作路徑: /tool mac-server sessions

屬性描述

interface (只讀: name) –連接客戶端的接口

src-address (只讀: MAC address) – 客戶 mac 地址(源地址)

uptime (只讀: 時間) –客戶端連接到服務器上的時間

查看 mac 地址連接訪問:


[RouterOS@ROSABC] tool mac-server sessions> print
# INTERFACE SRC-ADDRESS UPTIME
0 wlan1 00:0B:6B:31:08:22 00:03:01
[RouterOS@ROSABC] tool mac-server sessions>

MAC telnet 訪問客戶端



操作路徑: /tool mac-telnet

(MAC address) – 兼容設備的 mac 地址 通過 MAC 地址登陸遠程的 RouterOS:


[RouterOS@ROSABC] > /tool mac-telnet 00:02:6F:06:59:42
Login: admin
Password:

[RouterOS@ROSABC] >

沙發
發表于 2013-4-24 22:07:22 | 只看該作者
ROS軟路由論壇
造福大眾 驚才絕艷~
板凳
發表于 2013-5-28 10:06:32 | 只看該作者
asdfsafdsfgdsgdfg
地板
發表于 2013-5-30 14:07:11 | 只看該作者
不錯,不錯
5
發表于 2013-5-31 14:03:46 | 只看該作者
絕對給力
6
發表于 2013-6-10 10:50:47 | 只看該作者
正在學習研究 ros
7
發表于 2013-6-13 04:10:42 | 只看該作者
好帖要頂,樓主的頭像還是不錯滴

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖

                               
登錄/注冊后可看大圖
8
發表于 2013-6-13 09:41:12 | 只看該作者
SEE SEE SEE SEE SEE
9
發表于 2013-6-16 03:28:06 | 只看該作者
G強!!!!強!!!!
10
發表于 2013-6-18 11:12:07 | 只看該作者
學學學學學
您需要登錄后才可以回帖 登錄 | 會員注冊

本版積分規則

ROS教程版塊已全面開放,
即使是新注冊的初級會員也可閱讀全部內容。

不良信息舉報Q:2000617 點擊留言

不良信息舉報Q:2000617|Archiver|小黑屋|ROS軟路由論壇 ROSABC.com

GMT+8, 2020-1-26 03:13 , Processed in 0.204874 second(s), 21 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回復 返回頂部 返回列表
美女任你摸-美女禁区-美女销魂